[RFC,v3,05/19] batman-adv: Add aggregated_ogms mesh genl configuration

Message ID 20181207135846.6152-6-sven@narfation.org (mailing list archive)
State RFC, archived
Delegated to: Simon Wunderlich
Headers
Series batman-adv: netlink restructuring, part 2 |

Commit Message

Sven Eckelmann Dec. 7, 2018, 1:58 p.m. UTC
  The mesh interface can delay OGM messages to aggregate different ogms
together in a single OGM packet.

The BATADV_CMD_SET_MESH/BATADV_CMD_GET_MESH commands allow to set/get the
configuration of this feature using the BATADV_ATTR_AGGREGATED_OGMS
attribute. Setting the u8 to zero will disable this feature and setting it
to something else is enabling this feature.

Signed-off-by: Sven Eckelmann <sven@narfation.org>
---
Cc: Marek Lindner <mareklindner@neomailbox.ch>
---
 include/uapi/linux/batman_adv.h |  6 ++++++
 net/batman-adv/netlink.c        | 12 ++++++++++++
 2 files changed, 18 insertions(+)
  

Comments

Linus Lüssing Jan. 4, 2019, 1:40 a.m. UTC | #1
On Fri, Dec 07, 2018 at 02:58:32PM +0100, Sven Eckelmann wrote:
> +	/**
> +	 * @BATADV_ATTR_AGGREGATED_OGMS: whether the batman protocol messages
> +	 *  of the mesh mesh interface shall be aggregated or not.
> +	 */
> +	BATADV_ATTR_AGGREGATED_OGMS,
> +

I'm wondering, would it make sense to take this opportunity to
rename this to BATADV_ATTR_AGGREGATION? In case we were adding
aggregation support to something other than OGMs in the future.

(and maybe even make it a u32 to be able to potentially use it as
a bitfield with a useable length?)

And I know, the generic aggregation patchset was rejected. But on
the other hand I don't think that OGMs are that special that they
will always be the only packet type worth aggregating.
  
Linus Lüssing Jan. 4, 2019, 2:06 a.m. UTC | #2
On Fri, Dec 07, 2018 at 02:58:32PM +0100, Sven Eckelmann wrote:
> diff --git a/include/uapi/linux/batman_adv.h b/include/uapi/linux/batman_adv.h
> index 865cdf90..a01d90ed 100644
> --- a/include/uapi/linux/batman_adv.h
> +++ b/include/uapi/linux/batman_adv.h
> @@ -350,6 +350,12 @@ enum batadv_nl_attrs {
>  	 */
>  	BATADV_ATTR_VLANID,
>  
> +	/**
> +	 * @BATADV_ATTR_AGGREGATED_OGMS: whether the batman protocol messages
> +	 *  of the mesh mesh interface shall be aggregated or not.
> +	 */
> +	BATADV_ATTR_AGGREGATED_OGMS,
> +

"mesh mesh" -> "mesh"
  
Sven Eckelmann Jan. 4, 2019, 7:59 a.m. UTC | #3
On Friday, 4 January 2019 02.40.06 CET Linus Lüssing wrote:
> On Fri, Dec 07, 2018 at 02:58:32PM +0100, Sven Eckelmann wrote:
> > +	/**
> > +	 * @BATADV_ATTR_AGGREGATED_OGMS: whether the batman protocol messages
> > +	 *  of the mesh mesh interface shall be aggregated or not.
> > +	 */
> > +	BATADV_ATTR_AGGREGATED_OGMS,
> > +
> 
> I'm wondering, would it make sense to take this opportunity to
> rename this to BATADV_ATTR_AGGREGATION? In case we were adding
> aggregation support to something other than OGMs in the future.
> 
> (and maybe even make it a u32 to be able to potentially use it as
> a bitfield with a useable length?)
> 
> And I know, the generic aggregation patchset was rejected. But on
> the other hand I don't think that OGMs are that special that they
> will always be the only packet type worth aggregating.
> 

Any suggestions from Jiri regarding this?

Kind regards,
	Sven
  

Patch

diff --git a/include/uapi/linux/batman_adv.h b/include/uapi/linux/batman_adv.h
index 865cdf90..a01d90ed 100644
--- a/include/uapi/linux/batman_adv.h
+++ b/include/uapi/linux/batman_adv.h
@@ -350,6 +350,12 @@  enum batadv_nl_attrs {
 	 */
 	BATADV_ATTR_VLANID,
 
+	/**
+	 * @BATADV_ATTR_AGGREGATED_OGMS: whether the batman protocol messages
+	 *  of the mesh mesh interface shall be aggregated or not.
+	 */
+	BATADV_ATTR_AGGREGATED_OGMS,
+
 	/* add attributes above here, update the policy in netlink.c */
 
 	/**
diff --git a/net/batman-adv/netlink.c b/net/batman-adv/netlink.c
index 30ed0672..862d47c4 100644
--- a/net/batman-adv/netlink.c
+++ b/net/batman-adv/netlink.c
@@ -139,6 +139,7 @@  static const struct nla_policy batadv_netlink_policy[NUM_BATADV_ATTR] = {
 	[BATADV_ATTR_MCAST_FLAGS]		= { .type = NLA_U32 },
 	[BATADV_ATTR_MCAST_FLAGS_PRIV]		= { .type = NLA_U32 },
 	[BATADV_ATTR_VLANID]			= { .type = NLA_U16 },
+	[BATADV_ATTR_AGGREGATED_OGMS]		= { .type = NLA_U8 },
 };
 
 /**
@@ -214,6 +215,10 @@  static int batadv_netlink_mesh_put(struct sk_buff *msg,
 			goto nla_put_failure;
 	}
 
+	if (nla_put_u8(msg, BATADV_ATTR_AGGREGATED_OGMS,
+		       !!atomic_read(&bat_priv->aggregated_ogms)))
+		goto nla_put_failure;
+
 	batadv_hardif_put(primary_if);
 
 	genlmsg_end(msg, hdr);
@@ -295,6 +300,13 @@  static int batadv_netlink_get_mesh(struct sk_buff *skb, struct genl_info *info)
 static int batadv_netlink_set_mesh(struct sk_buff *skb, struct genl_info *info)
 {
 	struct batadv_priv *bat_priv = info->user_ptr[0];
+	struct nlattr *attr;
+
+	if (info->attrs[BATADV_ATTR_AGGREGATED_OGMS]) {
+		attr = info->attrs[BATADV_ATTR_AGGREGATED_OGMS];
+
+		atomic_set(&bat_priv->aggregated_ogms, !!nla_get_u8(attr));
+	}
 
 	batadv_netlink_notify_mesh(bat_priv);